HDU6188 | 2017广西邀请赛 Duizi and Shunzi (贪心)

 

Duizi and Shunzi

 

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 401    Accepted Submission(s): 207

 

 

Problem Description

Nike likes playing cards and makes a problem of it.

Now give you n integers, ai(1≤i≤n)

We define two identical numbers (eg: 2,2) a Duizi,
and three consecutive positive integers (eg: 2,3,4) a Shunzi.

Now you want to use these integers to form Shunzi and Duizi as many as possible.

Let s be the total number of the Shunzi and the Duizi you formed.

Try to calculate max(s).

Each number can be used only once.

 

 

Input

The input contains several test cases.

For each test case, the first line contains one integer n(1≤n≤106). 
Then the next line contains n space-separated integers ai (1≤ai≤n)

 

 

Output

For each test case, output the answer in a line.

 

 

Sample Input

 

7 1 2 3 4 5 6 7 9 1 1 1 2 2 2 3 3 3 6 2 2 3 3 3 3 6 1 2 3 3 4 5

 

 

Sample Output

 

2 4 3 2

Hint

Case 1(1,2,3)(4,5,6) Case 2(1,2,3)(1,1)(2,2)(3,3) Case 3(2,2)(3,3)(3,3) Case 4(1,2,3)(3,4,5)

 

 

Source

2017ACM/ICPC广西邀请赛-重现赛(感谢广西大学)

 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6188

 

 

思路:首先取对子,再取顺子,对于前两个数优先取对子,第三个数优先取顺子。

代码如下:

 

#include <bits/stdc++.h>
#define LL long long
using namespace std;

const int maxn = 1e6 + 10;
int n,a[maxn];

int main(){
	while(~scanf("%d",&n)){
		int num;
		memset(a,0,sizeof(a));
		for(int i = 1; i <= n; i ++){
			scanf("%d",&num); a[num] ++;
		}
		LL ans = 0;
		for(int i = 1; i <= n; i ++){
			ans += a[i] / 2;
			a[i] %= 2;
			if(i + 1 < n && a[i] && a[i+1] % 2 && a[i+2]){
				ans ++; a[i] --; a[i+1] --; a[i+2] --;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值