POJ2229 Sumsets (dp)

33 篇文章 1 订阅
9 篇文章 0 订阅
Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 20004 Accepted: 7814

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source


思路:当i为奇数的时候,就相当于i-1的每项都加上1,所以dp[i] = dp[i-1]。当i为偶数的时候,当i的各种划分中不存在1的时候,则是等于dp[i/2]的划分,当i中存在1时(则至少存在两个),等于dp[i-2]的划分。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define LL long long
using namespace std;

const int maxn = 1e6 + 10;
const int mod = 1e9;
LL dp[maxn],n;

void Init(){
	dp[0] = 1;
	for(int i = 1; i < maxn; i ++){
		if(i & 1) dp[i] = dp[i-1];
		else dp[i] = (dp[i-1] + dp[i >> 1]) % mod;
	} 
}

int main(){
	Init();	
	while(~scanf("%lld",&n)){
		printf("%lld\n",dp[n]);
	}
	return 0;
}
说下另一种思路,打表找规律:dfs打出前几个数的表然后找规律
打表代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n,ans;

void dfs(int k, int cur, int b[], int sum){
	if(sum == n){
//		for(int i = 0; i < cur; i ++) printf("%3d",b[i]); printf("\n");
		ans ++;
		return ;
	}
	if(sum > n) return;
	for(int i = k; i >= 1; i /= 2){
		b[cur] = i;
		dfs(i,cur+1,b,sum+i);
	}
}

int main(){
	int b[1000];
	while(~scanf("%d",&n)){
		int k = 1;
		ans = 0;
		while(k*2 <= n) k*=2;
		dfs(k,0,b,0);
		printf("%d===\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值