POj2348 Euclid's Game (博弈)

33 篇文章 1 订阅
24 篇文章 0 订阅

Euclid's Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9928 Accepted: 4063

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 
         25 7

         11 7

          4 7

          4 3

          1 3

          1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

Source

题目链接: http://poj.org/problem?id=2348

【题意】有两个数a,b,每次用较大的数减去较小的数的倍数,知道为0为止,面对(0,x)的这个状态必败,根据给定的输入的数,判断谁能够获胜。

【思路】假设a>b,对于a-b<b这个状态点,只需要判断后继状态点是P还是N即可,两者的状态肯定不一样;对于a-b>=b的状态点一定是比必胜态,因为无论后面的点是必胜态还是必败态,该点都可以转化成必胜态。

【代码如下】

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int a,b;

int main(){
    while(~scanf("%d%d",&a,&b)){
        if(a == 0 && b == 0) break;
        int flag = 0;
        for(; ; ){
            if(a < b) swap(a,b);
            if(a % b == 0) break;
            if(a - b >= b) break;
            flag = !flag;
            a %= b;
        }
        if(!flag) printf("Stan wins\n");
        else printf("Ollie wins\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值