POJ1704 Georgia and Bob(博弈)

33 篇文章 1 订阅
24 篇文章 0 订阅

Georgia and Bob
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11346 Accepted: 3746

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source


题目链接:http://poj.org/problem?id=1704

【题意】在一行格子中有n个棋子,每颗棋子可以向左移动至少一步(不能跨过其他棋子,不能越界),当前选手不能移动,则失败。Georgia为先手。

【思路】求出两两棋子之间的空格数,按照尼姆博弈异或求和即可。

【分析】把两棋子之间的空格数看做尼姆博弈中某堆石子的个数,当移动右侧棋子时,空格数减少(相当于从石子堆中取石子);当移动左侧棋子时,空格数增加,但是后手可以通过移动右侧棋子来使得空格数目减少。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int t,n,a[1100],b[1100];

int main(){
    scanf("%d",&t);
    while(t --){
        scanf("%d",&n);
        a[0] = 0;
        for(int i = 1; i <= n; i ++) scanf("%d",&a[i]);
        sort(a+1,a+n+1);
        int k = 0;
        for(int i = 2 - (n % 2); i <= n; i += 2){
            b[k ++] = a[i] - a[i-1]-1;
        }
        int ans = 0;
        for(int i = 0; i < k; i ++) ans ^= b[i];
        if(ans) printf("Georgia will win\n");
        else printf("Bob will win\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值