Georgia and Bob(尼姆博弈)

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

解题思路

由于任何两个相邻的棋子只与他们之间的空位有关,所以可以转化为普通的Nim游戏:我们可以把这些空位看作是石子数,谁取得了最后一个空位,谁就是赢家。之前做的还特
意奇数偶数棋子分开写,其实没必要如果只剩一个,就将棋盘左端加一格放一颗棋子与之配对。从后往前相减再异或,奇数时自然会用到stair[0],这里将相邻两颗棋子分作一组
(棋子不重复分组),其间距离当作之前题目中石子的个数,如果面临必胜态,当对手移动一组中靠左边的棋子时,我们只需将靠右的那一颗移动相同步数即可!维持数据,在
对手移动两颗棋子中靠右的那一颗时,我们就和他玩取石子游戏。



AC代码

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int T, n, sum, stairs[10005];
	scanf("%d", &T);
	while( T-- )
        {
		scanf("%d", &n);
		stairs[0]=0;
		for(int i=1; i<=n; i++)
			scanf("%d", &stairs[i]);
		sort(stairs, stairs+n+1);
		sum=0;
		for(int i=n; i>0; i-=2)
			sum ^= (stairs[i]-stairs[i-1]-1);

		if( sum==0 )
			printf("Bob will win\n");
		else
            printf("Georgia will win\n");
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值