POJ 1704 Georgia and Bob (尼姆博弈变形)

Georgia and Bob

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 16235Accepted: 5446

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:


Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

题意分析:

Georgia and Bob决定玩一个自己发明的游戏。他们在纸上画一排格子,将格子从左到右依次编号为1、2、3、……,将N个棋子放在不同的格子上,如下图为例:

每个人每次只能向右移动一枚棋子,棋子碰到前面已经有的棋子便无法移动,谁最后无法移动棋子谁输。

解题思路:
将两枚棋子和中间的空格看成一组,有两种情况:
1. 棋子数是奇数,这时将第一个棋子和有边界看成一组

2. 棋子是偶数,两两一组

我们要解决的问题就变成了判断谁先拿完组合组之间的空格

为什么我们不管组之间的空格呢?

我们可以与一个例子理解一下:

棋局如果是这个情况,可见只能动4和6 

Georgia先动,因为两个人都是世界第一聪明,所以Georgia知道这时候动4肯定输,所以只能动6

Bob这时候只能动4

可见这时,组内的空格数量并不会变化,变化的只有组和组之间的空格(话句话说,组内空格不会影响结果) 

这时我们就可以看出来这个题就是Nim博弈的一个变型

比较坑的一个点就是

棋子坐标的输入是随机的 不能忘了排序

AC代码

#include<iostream>
#include<algorithm> 
using namespace std;

const int N=1e4+5;
int a[N];
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n;
		cin>>n;
		for(int i = 0; i < n; i++) cin>>a[i];
		if(n&1) a[n++]=0;//如果为奇数,则把墙和第一个棋子作为一组 
		sort(a,a+n);
		int ans=0;
		for(int i = 1; i < n; i += 2)//两两一组,取每组之间的空格数 ,先手能先取完,先手胜 
			ans^=(a[i]-a[i-1]-1);
		if(!ans) cout<<"Bob will win"<<endl;
		else cout<<"Georgia will win"<<endl;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值