POJ3537 Crosses and Crosses (Multi-SG)

33 篇文章 1 订阅
24 篇文章 0 订阅

Crosses and Crosses
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 4059 Accepted: 1591
Case Time Limit: 2000MS

Description

The game of Crosses and Crosses is played on the field of 1 × n cells. Two players make moves in turn. Each move the player selects any free cell on the field and puts a cross ‘×’ to it. If after the player’s move there are three crosses in a row, he wins.

You are given n. Find out who wins if both players play optimally.

Input

Input file contains one integer number n (3 ≤ n ≤ 2000).

Output

Output ‘1’ if the first player wins, or ‘2’ if the second player does.

Sample Input

 
#13
#26

Sample Output

 
#11
#22

Source

Northeastern Europe 2007, Northern Subregion

题目链接:http://poj.org/problem?id=3537

【题意】有一个1*n的棋盘,两个选手轮流在一个空白的棋格上放X,当某个选手在棋盘上放上X后构成连续的三个X,则该选手获胜。

【思路】假设在第i个棋格处放一个X,则i-2,i-1,i+1,i+2处都不应该放(如果在放了,则必输),所有这个游戏就可以分成1*(i-3)和(n-(i+2))的两个游戏,然后按照sg求异或值即可。

【代码如下】

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int sg[2100],n;

int dfs(int x){
    if(x <= 0) return 0;
    if(~sg[x]) return sg[x];
    bool vis[2100] = {false};
    for(int i = 1; i <= x; i ++){
        vis[dfs(i-3) ^ dfs(x - (i+2))] = true;
    }
    for(int i = 0; ; i ++){
        if(!vis[i]){
            sg[x] = i; break;
        }
    }
    return sg[x];
}

int main(){
    while(~scanf("%d",&n)){
        memset(sg,-1,sizeof(sg));
        printf("%d\n",dfs(n) ? 1 : 2);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值