【PAT-甲级】1001-A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

AC代码: 

#include<iostream>
#include<string>
using namespace std;
int main()
{
    int a, b;
    cin >> a >> b;
    int sum = a + b;
    cout << (sum < 0 ? "-" : "");
    sum = sum < 0 ? -sum : sum;
    string s = to_string(sum);
    while (s.size() > 0)
    {
        cout << s[0];
        s = s.substr(1);
        if (s.size() % 3 == 0 && s.size())
            cout << ',';
    }
    return 0;
}

 我觉得仍然是属于找规律了,怎么把那个,在合适的位置输出出来。substr最开始我用的是循环处理的,后来想起了这个成员函数。强大的标准库几乎把任何合理的常规操作都封装成库函数了。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值