【PAT-甲级】1055 The World‘s Richest

题目:

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

AC代码:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>

using namespace std;

struct Peo
{
	string name;
	int age;
	int asset;
};
// 财产降,年龄升,名字升
bool cmp1(Peo p1, Peo p2)
{
	return p1.asset != p2.asset ? p1.asset > p2.asset:(p1.age != p2.age ? p1.age < p2.age : p1.name < p2.name);
}
int main()
{
	int n, num;
	cin >> n >> num;
	vector<Peo> v, v2;
	for (int i = 0; i < n; i++)
	{
		Peo p;
		cin >> p.name >> p.age >> p.asset;
		v.push_back(p);
	}
	sort(v.begin(), v.end(), cmp1);
	int age[201] = { 0 };
	for (auto& i : v)
	{
		if (age[i.age] < 100)
		{
			v2.push_back(i);
			++age[i.age];
		}
	}
	for (int i = 1; i <= num; i++)
	{
		cout << "Case #" << i << ":" << endl;
		int n = 0;
		int age1, age2;
		cin >> n >> age1 >> age2;
		int flag = 1;
		for (int i = age1; i <= age2; i++)
		{
			if (age[i])
				flag = 0;   //如果有人flag=0;
		}
		if (flag)
		{
			cout << "None" << endl;
			continue;
		}
		for (auto& i : v2)
		{
			if (i.age >= age1 && i.age <= age2)
			{
				cout << i.name << " " << i.age << " " << i.asset << endl;
				--n;
				if (!n)
					break;
			}
		}
	}
	return 0;
}

 此题其实逻辑理解上并不难,就是按照某个条件找出某些元素,然后排序即可。只是测试点2容易超时,如果用常规解法是无法通过的(写了很多超时解法,每次更新都没有从根本上解决问题)。即:不能针对每个年龄区域都遍历整个容器,然后再针对年龄区域内的再次排序或者输出。 

核心是:最多有100000个人,但是针对每个年龄段最多只可能需要输出前100个富有的人,所以先按照财富排序整个容器,然后创建一个数组,用于记录每个年龄的人数,然后遍历整个数组,在某个年龄不超过100人的情况下,把符合条件的人放入另一个容器中,这样的话,这个容器存放的实际上是所有年龄里,最富有的100人。即使是每个年龄的人都很多,最多也是200*100=20000个人,况且如果根据实际情况,年龄大于100的人应该没几个= =。  

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值