POJ 1007 DNA Sorting 多个数组代替结构体

DNA Sorting

Time Limit: 1 Sec   Memory Limit: 64 MB
Submit: 327   Solved: 140
[ Submit][ Status][ Discuss]

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).



You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

HINT

poj1007

Source

East Central North America 1998

        该题为我们提供了一种可代替结构体的方法(但是相比于结构体很是笨重)。
题目要求我们记录一个主体及它的一些属性(总称为 块),当其中一项改变时,整个块也要发生改变,很显然,结构体可以轻易地做到这些,but,我们有两个数组同样可以实现,只是改变时,要改变两个数组。以题目中按最大值顺序排列举例,如果用结构体来做,可以用一个参数在一个步骤里实现,而用数组的话,相当于分两次改变两个数组的内容。
AC代码:
 
#include<stdio.h>
#include<string.h>
int main()
{
    int i,p,j,n,m,k,y,x;
    int num[102]={0};
    char mid[54],fir[102][52];
    scanf("%d %d",&m,&n);
    getchar();
    for(i=1;i<=n;i++)
    {
        y=0;
        gets(fir[i]);
        for(j=0;j<=m-2;j++)
            for(p=j+1;p<=m-1;p++)
                if(fir[i][j]>fir[i][p])
                    y++;
        num[i]=y;
    }
    for(i=1;i<=n;i++)
    {
        k=i;
        for(j=i+1;j<=n;j++)
        {
            if(num[k]>num[j])
                k=j;
        }
        strcpy(mid,fir[k]);
        strcpy(fir[k],fir[i]);
        strcpy(fir[i],mid);
        x=num[k];
        num[k]=num[i];
        num[i]=x;
    }
    for(i=1;i<=n;i++)
        puts(fir[i]);
    return 0;
}


下面这个代码在POJ上WA了,不知道为什么。。。。
#include<stdio.h>
#include<string.h>
char sec[1500][5001];
int main()
{
    int i,p,j,n,m,x,y;
    char first[105][52];
    char c;
    scanf("%d %d",&n,&m);
    getchar();
    y=0;
    for(i=1;i<=m;i++)
        gets(first[i]);
    for(i=1;i<=m;i++)
    {
        x=0;
        for(j=0;j<=n-1;j++)
        {
            for(p=j+1;p<=n-1;p++)
                if(first[i][j]>first[i][p])
                    x++;
        }
        if(sec[x][0]!=0)
        {
            first[i][n]='\n';
            first[i][n+1]=0;
        }
        strcat(sec[x],first[i]);
    }
    printf("%d\n",x);
    for(i=0;i<=1500;i++)
        if(sec[i][0]!=0)
            puts(sec[i]);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值