Tic-Tac-Toe

Tic-Tac-Toe

Kim likes to play Tic-Tac-Toe.

Given a current state, and now Kim is going to take his next move. Please tell Kim if he can win the game in next 2 moves if both player are clever enough.

Here “next 2 moves” means Kim’s 2 move. (Kim move,opponent move, Kim move, stop).

Game rules:

Tic-tac-toe (also known as noughts and crosses or Xs and Os) is a paper-and-pencil game for two players, X and O, who take turns marking the spaces in a 3×3 grid. The player who succeeds in placing three of their marks in a horizontal, vertical, or diagonal row wins the game.


Input

First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.

For each test case: Each test case contains three lines, each line three string(“o” or “x” or “.”)(All lower case letters.)

x means here is a x

o means here is a o

. means here is a blank place.

Next line a string (“o” or “x”) means Kim is (“o” or “x”) and he is going to take his next move.

Output

For each test case:

If Kim can win in 2 steps, output “Kim win!”

Otherwise output “Cannot win!”

Sample Input
3
. . .
. . .
. . .
o
o x o
o . x
x x o
x
o x .
. o .
. . x
o
Sample Output
Cannot win!
Kim win!
Kim win!
#include <iostream>
#include<algorithm>
#include<stdlib.h>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<deque>
#include<stack>
using namespace std;
char a[10][10],b;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int i,j;
        for(i=1;i<4;i++)
        for(j=1;j<4;j++)
        scanf(" %c",&a[i][j]);
        scanf(" %c",&b);
        if(a[2][2]==b&&((a[1][1]==b&&((a[1][3]=='.'||a[1][3]==b)&&(a[3][1]=='.'||a[3][1]==b)))||(a[3][3]==b&&((a[1][3]=='.'||a[1][3]==b)&&(a[3][1]=='.'||a[3][1]==b)))||(a[1][3]==b&&((a[1][1]=='.'||a[1][1]==b)&&(a[3][3]=='.'||a[3][3]==b)))||(a[3][1]==b&&((a[1][1]=='.'||a[1][1]==b)&&(a[3][3]=='.'||a[3][3]==b)))))
        printf("Kim win!\n");
        else
        {
            int x=0,y=0,z=0;
            for(int k=1;k<4;k++)
            {
                x=0;
                y=0;
                    if(a[k][1]=='.')
                    x++;
                    if(a[k][1]==b)
                    y++;
                    if(a[k][2]=='.')
                    x++;
                    if(a[k][2]==b)
                    y++;
                     if(a[k][3]=='.')
                    x++;
                    if(a[k][3]==b)
                    y++;
                    if(x==1&&y==2)
                    z=1;
                    if(y==3)
                    z=1;
//printf("%d %d\n",x,y);
            }

            for(int k=1;k<4;k++)
            {
                x=0;
                y=0;
                    if(a[1][k]=='.')
                    x++;
                    if(a[1][k]==b)
                    y++;
                    if(a[2][k]=='.')
                    x++;
                    if(a[2][k]==b)
                    y++;
                     if(a[3][k]=='.')
                    x++;
                    if(a[3][k]==b)
                    y++;
                    if(x==1&&y==2)
                    z=1;
                    if(y==3)
                    z=1;
                    //printf("%d %d\n",x,y);

            }
            x=0;
            y=0;
            for(int k=1;k<4;k++)
            {
                if(a[k][k]=='.')
                x++;
                if(a[k][k]==b)
                y++;
            }
            //printf("%d %d\n",x,y);
            if(x==1&&y==2)
                    z=1;
                    if(y==3)
                    z=1;
                x=0;
                y=0;
                for(int k=1;k<4;k++)
            {
                if(a[k][4-k]=='.')
                x++;
                if(a[k][4-k]==b)
                y++;
            }
            if(x==1&&y==2)
                    z=1;
                    if(y==3)
                    z=1;
                    //printf("%d %d\n",x,y);
                if(z==1)
                printf("Kim win!\n");
                else
                printf("Cannot win!\n");


        }

    }
}
井字棋游戏。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值