Set Mismatch

题目描述

The set S originally contains numbers from 1 to n. But unfortunately, due to the data error, one of the numbers in the set got duplicated to another number in the set, which results in repetition of one number and loss of another number.

Given an array nums representing the data status of this set after the error. Your task is to firstly find the number occurs twice and then find the number that is missing. Return them in the form of an array.

输入

第一行一个数n表示数字的数量(n<=100)

第二行给出n个数

输出

在一行内输出两个数分别表示出现两次的数的和未出现过的数

样例输入

4
1 2 2 4

样例输出

2 3
#include<iostream>
using namespace std;
int main()
{
    int n,i,k;
    cin>>n;
    int  a[100]={0},b[100]={0};
    for(i=0;i<n;i++)
      {
            cin>>a[i];
            k=a[i];
            b[k]++;
      }
for(i=1;i<=n;i++)
{
      if(b[i]==2)
            cout<<i<<" ";
}
for(i=1;i<=n;i++)
{
      if(b[i]==0)
            cout<<i;
}
   return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

深度学习推荐算法

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值