练习三 Problem E

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.<br><br>The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. <br><br>They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. <br><br>Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.<br>

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,<br>representing the number of different blocks in the following data set. The maximum value for n is 30.<br>Each of the next n lines contains three integers representing the values xi, yi and zi.<br>Input is terminated by a value of zero (0) for n.<br>

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".<br>

Sample Input
    
    
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0

Sample Output
    
    
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342


题意:有一群猴子,和一些不同的木板,每种类型的木板有无限多块,猴子要想得到食物就必须通过木板叠加起来,问这些木板可以叠加的最高是多少,要求上层木板的长、宽皆比下层的小。。。


解题思路:每块木板有三种放法,所以就当作是三种木板,将输入的n块木板变成3n块木板,然后比较其长与宽的大小然后依次摆放,最终求出放木块的最大高度。


感想:代码实现有点难度,而且不是最优解。。。。

                                                                                                                                                   

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct stu{
 int x,y,z,h;
}s[1000];
int cmp1(const void*a,const void*b)
{
 return *(int *)b-*(int *)a;
}
int cmp2(const void*a,const void*b)
{
 struct stu *c,*d;
 c=(struct stu*)a;
 d=(struct stu*)b;
 return d->x*d->y-c->x*c->y;
}
int main()
{
 int n,i,a[3],m,max,j,q=1;;
 while(scanf("%d",&n),n)
 {
  memset(s,0,sizeof(s));
  i=0;
  while(n--)
  {
   scanf("%d%d%d",&a[0],&a[1],&a[2]);
   qsort(a,3,sizeof(a[0]),cmp1);
   s[i].x=a[0];s[i].y=a[1];s[i++].z=a[2];
   s[i].x=a[1];s[i].y=a[2];s[i++].z=a[0];
            s[i].x=a[0];s[i].y=a[2];s[i++].z=a[1];
  }
  m=i;
  qsort(s,m,sizeof(s[0]),cmp2);
  s[0].h=s[0].z;
  for(i=1;i<m;i++)
  {
   max=0;
   for(j=0;j<i;j++)
   {
    if(s[j].h>max&&s[j].x>s[i].x&&s[j].y>s[i].y)
     max=s[j].h;
   }
   s[i].h=s[i].z+max;
  }
  max=0;
  for(i=0;i<m;i++)
  {
   if(s[i].h>max)
    max=s[i].h;
  }
  printf("Case %d: maximum height = %d\n",q++,max);
 }
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值