[单调队列] POJ2823 Sliding Window (滑动窗口的最值问题)

题目

 An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position     Minimum value   Maximum value
[1  3  -1] -3  5  3  6  7   -1  3
 1 [3  -1  -3] 5  3  6  7   -3  3
 1  3 [-1  -3  5] 3  6  7   -3  5
 1  3  -1 [-3  5  3] 6  7   -3  5
 1  3  -1  -3 [5  3  6] 7   3   6
 1  3  -1  -3  5 [3  6  7]  3   7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input
The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

思路

单调队列裸题。
我的方法见借鉴于aoapc-ch8例题-平均值,LRJ的代码。那道题里面是单调栈,意思差不多。

代码

//由于POJ抽风,本代码并没有去测评,只是过了样例。
#include <cstdlib>
#include <cstdio>

const int maxn = 1000000 + 1000;
int n, k, A[maxn], p[maxn], ans1[maxn], ans2[maxn];

int main() {
    scanf("%d%d", &n, &k);
    for (int i = 0; i < n; i++)
        scanf("%d", &A[i]);

    int i = 0, j = 0;  // 单调队列区间为 [i, j)
    for (int t = 0; t < n; t++) {
        if (t >= k && p[i] == A[t-k]) i++;   // 将第一个区间填满后,并且当前队首元素是窗口队首元素,将其出队。
        while (i<j && p[j - 1] > A[t]) j--;   // 使区间单调
        p[j++] = A[t];
        if (t >= k - 1) ans1[t - k + 1] = p[i];
    }

    i = 0, j = 0;
    for (int t = 0; t < n; t++) {
        if (t >= k && p[i] == A[t - k]) i++;
        while (i<j && p[j - 1] < A[t]) j--;
        p[j++] = A[t];
        if (t >= k - 1) ans2[t - k + 1] = p[i];
    }

    for (int i = 0; i <= n - k; i++)
        printf("%d ", ans1[i]);
    printf("\n");
    for (int i = 0; i <= n - k; i++)
        printf("%d ", ans2[i]);
    printf("\n");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值