【POJ 1797】Heavy Transportation(最短路dij)

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题目大意

题目大概就是说有m座桥,每座桥都有一个负重,超过这个负重桥就会塌掉。现在问你从1到N用汽车运货最大能运多重的东西。

思路

同样用dij跑最短路,但是在选边和更新时需要修改,因为要求的不是整条线路的最小花费而是求在这条线路中最大能承受的重量,比如样例中1~3有以下两种走法:
①1-2-3:其中1-2权重3,2-3权重5,但是最大能承受的重量只能是3,因为超过3,1-2这座桥就塌了。
②1-3:权重为4,所以最大能承受的重量为4.
还有题目有要求输出时需要输出2个回车。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int INF=0x3ffff;
const int maxn=1000+5;

int map[maxn][maxn],vis[maxn],dis[maxn],t,n,m;

void dij(int s)
{
    int pos;
    for(int i=1;i<=n;i++)
    {
        vis[i]=0;
        dis[i]=map[1][i];
    }
    for(int i=1;i<=n;i++)
    {
        int tmp=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&(dis[j]>tmp))
            {
                tmp=dis[j];
                pos=j;
            }
        }
        vis[pos]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]<min(dis[pos],map[pos][j]))
            {
                dis[j]=min(dis[pos],map[pos][j]);
            }
        }

    }
}

int main()
{
    scanf("%d",&t);
    int casetime=1;
    while(t--)
    {

        int s,e,v;
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                map[i][j]=0;
            }
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d %d %d",&s,&e,&v);
            if(map[s][e]==INF) map[s][e]=map[e][s]=v;
            else if(map[s][e]<v) map[s][e]=map[e][s]=v;
        }
        dij(1);
        printf("Scenario #%d:\n%d\n\n",casetime++,dis[n]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值