Heavy Transportation (Dijkstra算法变形)

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意:有n个城市,m条道路,在每条道路上只有一个承载量,要求从1到n的最大承载量,最大承载量就是所有通路的最大承载量

比如:1->2  3;  2->3 5  ,那么1->3最大承载量为3 

思路:首先找到和1相连的的点u和载重量最大值maxn,然后找出manx 和与u相连的点i之间的重量的最小值ans,最后拿这个最小值与dis[i]相比,如果ans>dis[i],则需要更新,反复进行这个过程,知道外层循环结束

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int n,m;
#define Inf 0x3f3f3f3f
const int N=1005;
int g[N][N];
bool vis[N];
int dis[N];
int Dijkstra()
{
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
	   dis[i]=g[1][i];
	vis[1]=1;
	for(int k=1;k<n;k++)
	{
		int maxn=0,u;
		for(int i=1;i<=n;i++)
		{
			if(!vis[i]&&maxn<dis[i])
			{
				maxn=dis[i];
				u=i;
			}
		}
		vis[u]=1;
		for(int i=1;i<=n;i++)
		{
			if(!vis[i])
			{
				int ans=min(maxn,g[u][i]);
				if(ans>dis[i])
				   dis[i]=ans;
			}
		}
	}
	return dis[n];
}
int main()
{
	int t;
	cin>>t;
	for(int i=1;i<=t;i++)
	{
		cin>>n>>m;
		memset(g,0,sizeof(g));
		for(int j=0;j<m;j++)
		{
			int a,b,w;
			cin>>a>>b>>w;
			g[a][b]=g[b][a]=w;
		}
		printf("Scenario #%d:\n",i);
		printf("%d\n\n",Dijkstra());
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

OUC_lkc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值