Heavy Transportation(最短路 Dijkstra)

Problem Description
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4

题意:有n个路口,m条街道,每条街道的权值代表这条街道的最大承受重量,求从编号1的路口到编号n的路口,最大承受重量为多少。

思路:用最短路算法Dijkstra,要注意的是,求的是每一条路径所能承受的最大重量,即每条路径的某个路段的最小承受重量。假设1 直接到 j的最大承重是6,以k为中转点,1 到 k的最大承重为5,k 到j 的最大承重为8,但是这条路1 到j 的最大承重也只能是5,因为要从1 通过k,最大只能承重为5,就算后面再路径的承重再大,前面承受不了也没用。所以要取最大承重, dis[ j ] = max(dis[ j ],min (dis[ k ],mapp[ k ][ j ]))。
具体修改的Dijkstra算法参见代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
#define N 1005
using namespace std;
int n,m;
int mapp[N][N],dis[N],vis[N];

void Dijkstra()
{
    memset(vis,0,sizeof(vis));
    //记录各点到起点的权重
    for(int i = 1; i<=n; i++)
    {
        dis[i] = mapp[1][i];
    }
    vis[1] = 1;

    for(int i = 0; i<n-1; i++)
    {
        int maxx = 0,k;
        for(int j = 1; j<=n; j++)//获取未确定点的最大值
        {
            if(maxx<dis[j] && !vis[j])
            {
                maxx = dis[j];
                k = j;
            }
        }
        vis[k] = 1;
        //求的是每一条路径所能承受的最大重量,即每条路径的某个路段的最小承受重量
        for(int j = 1; j<=n; j++)
        {
            dis[j] = max(dis[j],min(dis[k],mapp[k][j]));
        }
    }
}

int main()
{
    int t,a,b,c;
    scanf("%d",&t);
    for(int i = 1; i<=t; i++)
    {
        scanf("%d%d",&n,&m);
        for(int j = 1; j<=n; j++)
        {
            for(int k = 1; k<=n; k++)
            {
                mapp[j][k] = 0;//j==k?0:INF; 要求最大值,应该把它初始化为0,而不是INF
            }
        }
        for(int j = 1; j<=m; j++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(mapp[a][b]<c)
            {
                mapp[a][b] = c;
                mapp[b][a] = c;
            }
        }
        Dijkstra();
        printf("Scenario #%d:\n%d\n\n",i,dis[n]);
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值