HDU-5569 matrix(DP)

77 篇文章 0 订阅

matrix

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
Given a matrix with  n  rows and  m  columns (  n+m  is an odd number ), at first , you begin with the number at top-left corner (1,1) and you want to go to the number at bottom-right corner (n,m). And you must go right or go down every steps. Let the numbers you go through become an array  a1,a2,...,a2k .     The cost is  a1a2+a3a4+...+a2k1a2k .   What is the minimum of the cost?
 

Input
Several test cases(about  5 )

For each cases, first come 2 integers,  n,m(1n1000,1m1000)

n+m is an odd number.

Then follows  n  lines with  m  numbers  ai,j(1ai100)
 

Output
For each cases, please output an integer in a line as the answer.
 

Sample Input
  
  
2 3 1 2 3 2 2 1 2 3 2 2 1 1 2 4
 

Sample Output
  
  
4 8


很快就想到了DP,题真不是白做的


对于任意i,j,且i+j为奇数时,dp[i][j]只能从dp[i-2][j],dp[i-1][j-1],dp[i][j-2]转移过来。

其中:

①a[i-2][j]只能经过a[i-1][j]到达a[i][j],状态转移方程为:dp[i][j]=min(dp[i][j],dp[i-2][j],a[i-1][j]*a[i][j]);

②a[i][j-2]只能经过a[i][j-1]到达a[i][j],状态转移方程为:dp[i][j]=min(dp[i][j],dp[i][j-2],a[i][j-1]*a[i][j]);

③a[i][j]可分别经过a[i][j-1]和a[i-1][j]到达a[i][j],状态转移方程为:

dp[i][j]=min(dp[i][j],dp[i-1][j-1]+a[i][j]*min(a[i-1][j],a[i][j-1]));


合并后可得:

dp[i][j]=min(dp[i][j],min(min(dp[i-1][j-1],dp[i-2][j])+a[i][j]*a[i-1][j],min(dp[i-1][j-1],dp[i][j-2])+a[i][j]*a[i][j-1]));



#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int a[1005][1005],dp[1005][1005],n,m;

int main() {
    int i,j;
    while(scanf("%d%d",&n,&m)==2) {
        memset(dp,0x3f,sizeof(dp));
       dp[0][1]=dp[1][0]=0;
        for(i=1;i<=n;++i)
            for(j=1;j<=m;++j)
                scanf("%d",&a[i][j]);
        for(i=2;i<=n;++i)//先处理第1列,防止越界
            dp[i][1]=dp[i-2][1]+a[i][1]*a[i-1][1];
        for(j=2;j<=m;++j)//先处理第1行,防止越界
            dp[1][j]=dp[1][j-2]+a[1][j]*a[1][j-1];
        //没想到用“我为人人”型转移状态,这样就可以直接处理,不用担心越界了
        for(i=2;i<=n;++i)
            for(j=2;j<=m;++j)
                if((i+j)&1)
                    dp[i][j]=min(dp[i][j],min(min(dp[i-1][j-1],dp[i-2][j])+a[i][j]*a[i-1][j],min(dp[i-1][j-1],dp[i][j-2])+a[i][j]*a[i][j-1]));
        printf("%d\n",dp[n][m]);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值