HDU-5611 Baby Ming and phone number(模拟)

65 篇文章 0 订阅

Baby Ming and phone number

http://acm.hdu.edu.cn/showproblem.php?pid=5611

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
Baby Ming collected lots of cell phone numbers, and he wants to sell them for money.

He thinks normal number can be sold for  b  yuan, while number with following features can be sold for  a  yuan.

1.The last five numbers are the same. (such as 123-4567-7777)

2.The last five numbers are successive increasing or decreasing, and the diffidence between two adjacent digits is  1 . (such as 188-0002-3456)

3.The last eight numbers are a date number, the date of which is between Jar 1st, 1980 and Dec 31th, 2016. (such as 188-1888-0809,means August ninth,1888)

Baby Ming wants to know how much he can earn if he sells all the numbers.
 

Input
In the first line contains a single positive integer  T , indicating number of test case.

In the second line there is a positive integer  n , which means how many numbers Baby Ming has.(no two same phone number)

In the third line there are  2  positive integers  a,b , which means two kinds of phone number can sell  a  yuan and  b  yuan.

In the next  n  lines there are  n  cell phone numbers.(|phone number|==11, the first number can’t be 0)

1T30,b<1000,0<a,n100,000
 

Output
How much Baby Nero can earn.
 

Sample Input
  
  
1 5 100000 1000 12319990212 11111111111 22222223456 10022221111 32165491212
 

Sample Output
  
  
302000

水题,按照题意判断即可

忘了0开头的数字表示8进制,01234导致数字错误,浪费好长时间

#include <cstdio>

using namespace std;

const int days[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
const int fea[22]={ 0,11111,22222,33333,44444,55555,66666,77777,88888,99999,
                    1234,12345,23456,34567,45678,56789,
                    98765,87654,76543,65432,54321,43210
};

int T,n;
long long number,ans,a,b;

inline bool isSpic(int num) {
    for(int i=0;i<22;++i)
        if(num==fea[i])
            return true;
    return false;
}

inline int isleap(int year) {
    if((year%4==0&&year%100!=0)||year%400==0)
        return 1;
    return 0;
}

bool isDate(int year,int month,int day) {
    if(year<1980||year>2016||month==0||month>12||day==0)
        return false;
    if(month==2) {
        if(day>28+isleap(year))
            return false;
        return true;
    }
    if(day>days[month])
        return false;
    return true;
}

int main() {
    scanf("%d",&T);
    while(T--) {
        ans=0;
        scanf("%d%I64d%I64d",&n,&a,&b);
        while(n--) {
            scanf("%I64d",&number);
            ans+=(isSpic(number%100000)||isDate((number/10000)%10000,(number/100)%100,number%100))?a:b;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值