HDU-3709 Balanced Number (数位DP)

77 篇文章 0 订阅

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)


Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
  
  
2 0 9 7604 24324
 

Sample Output
  
  
10 897

题目大意:统计区间[l,r]中平衡数的个数?如果一个数以某一点为支点的力矩为0,则该数为平衡数。


又是一个状态很难想的数位DP

对于一个非0数x,最多只存在一个支点pivot使力矩为0

所以支点不同时的统计个数不重复(不包括0),可以直接相加

所以可以设dp[i][j][k]表示长度为i时,支点为j,且高位的数的力矩为k时,满足题意的数的个数

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MOD=2520;

int n,len,bit[25];
int ha[MOD];
long long l,r;
long long dp[25][25][1805];//dp[i][j][k]表示长度为i时,支点为j,且高位的数的力矩为k时,满足题意的数的个数

long long dfs(int pos,int pivot,int sum,bool limit) {//pos表示当前考虑的位,pivot为支点的位置,sum表示当前力矩和,limit表示当前位的数字上限是否有限制
    if(pos<=0) {
        return sum==0?1:0;
    }
    if(sum<0) {//如果当前力矩和已经小于0,则减去,因为力矩是非增的
        return 0;
    }
    if(!limit&&dp[pos][pivot][sum]!=-1) {
        return dp[pos][pivot][sum];
    }

    int mx=limit?bit[pos]:9;
    long long res=0;
    for(int i=0;i<=mx;++i) {
        res+=dfs(pos-1,pivot,sum+(pos-pivot)*i,limit&&i==mx);
    }
    if(!limit&&dp[pos][pivot][sum]==-1) {
        dp[pos][pivot][sum]=res;
    }
    return res;
}

long long getCnt(long long x) {//返回[0,x]中满足题意的数的答案
    if(x==-1) {
        return 0;
    }
    len=0;
    while(x>0) {
        bit[++len]=x%10;
        x/=10;
    }
    long long ans=0;
    for(int i=len;i>=1;--i) {//枚举支点
        ans+=dfs(len,i,0,true);
    }
    return ans-len+1;//0,00,...,000000等都算满足题意,但只能算作0,减去重复考虑的
}

int main() {
    int T;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&T);
    while(T-->0) {
        scanf("%lld%lld",&l,&r);
        printf("%lld\n",getCnt(r)-getCnt(l-1));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值