【杭电4883】TIANKENG’s restaurant

TIANKENG’s restaurant
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input

The first line contains a positive integer T(T<=100), standing for T test cases in all. 

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time. 

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough. 
 

Output

For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input

     
     
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output

     
     
11

6

刚开始以为是贪心问题,写了以下代码,结果错了wrong answer

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include<stdio.h>
#include<algorithm>
using namespace std;
struct stu
{
	int a,h[2],m[2];
}s[10000];
bool cmp(stu q,stu p)
{
	if(q.h[1]!=p.h[1])
	return q.m[1]<p.m[1];
	else return q.h[1]<p.h[1];
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			scanf("%d %d:%d %d:%d",&s[i].a,&s[i].h[0],&s[i].m[0],&s[i].h[1],&s[i].m[1]);
		sort(s,s+n,cmp);
		int sum=s[0].a;
		for(int i=1;i<n;i++)
		{
			if((s[i].h[0]>=s[i-1].h[1])||(s[i].h[0]==s[i-1].h[1]&&s[i].m[0]>s[i-1].m[1]))
			sum=sum;
			else
			sum=sum+s[i].a;
		}
		printf("%d\n",sum);
	}
	return 0;
}
而实际上是时间区域覆盖问题,在一段时间内,随时可能有下一组人来,所以正确代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int s[1500];
int main ()
{
	int T;
	scanf("%d", &T);
	while(T--){
		int m;
		scanf("%d", &m);
		int n, h1, m1, h2, m2, sum;
		memset(s, 0, sizeof(s));//数组清零
		sum = 0;
		while(m--){
			scanf("%d%d:%d%d:%d", &n, &h1, &m1, &h2, &m2);
			int t1=h1*60+m1;
			int t2=h2*60+m2;
			s[t1]+=n;
			s[t2]-=n;
		}
		for(int i=1; i<=1500;++i)
		{
			s[i]+=s[i - 1];
			sum=max(sum, s[i]);
		}
		printf("%d\n", sum); 
	}
	return 0;
} 
别人的代码:
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[100000];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,i;
		memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			int p,h1,m1,h2,m2,j;
			scanf("%d %d:%d %d:%d",&p,&h1,&m1,&h2,&m2);
			h1=h1*60+m1;
			h2=h2*60+m2;
			for(j=h1;j<h2;j++)  在此时间段内来的的就加上顾客数
				a[j]+=p;
		}
		printf("%d\n",*max_element(a,a+1500));
	}
}
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
  int a[2000];
  int T,m,i;
  scanf("%d",&T);
  while(T--)
  {
    int n,h1,h2,m1,m2;
    int sum1,sum2,maxx=0;
    scanf("%d",&m);
    memset(a,0,sizeof(a));
    while(m--)
    {
      scanf("%d%d:%d%d:%d",&n,&h1,&m1,&h2,&m2);
      sum1=h1*60+m1;
      sum2=h2*60+m2;
      for(i=sum1;i<sum2;i++)
      {
        a[i]+=n;<span style="font-family: 'Courier New', Courier, monospace; font-size: 15px; line-height: 35px; white-space: pre-wrap;"><span style="color:#ff0000;">计算相同时间内最多人数就好了</span></span>
        maxx=max(maxx,a[i]); 
      }
    }
    printf("%d\n",maxx);
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值