杭电4883-TIANKENG’s restaurant(区间覆盖)

5 篇文章 0 订阅
1 篇文章 0 订阅

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1801    Accepted Submission(s): 657


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
  
  
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
  
  
11 6
 

这个题大家都把他当成贪心了,其实不是的,这是一个区间覆盖和更新问题,把时间都换成分钟,更新区间求出最大值,要注意一点,6 08:00 09:005 09:00 10:00这个例子说明重叠的区间是不会算到上一个区间内的!



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int time[1500];
int main()
{
	int m,n,i,j,N,a,b,c,d,num;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d",&m);
		memset(time,0,sizeof(time));
		for(i=0;i<m;i++)
		{
			scanf("%d%d:%d%d:%d",&num,&a,&b,&c,&d);
			time[a*60+b]+=num;
			time[c*60+d]-=num;
		}
		int sum=0;
		for(i=1;i<=1440;i++)
		{
			time[i]+=time[i-1];
			sum=max(time[i],sum);
		}
		printf("%d\n",sum);
	}
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值