【杭电1865】1Sting 打表法 初学不懂!!

1sting
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get. 
 

Input

The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200. 
 

Output

The output contain n lines, each line output the number of result you can get . 
 

Sample Input

      
      
3 1 11 11111
 

Sample Output

      
      
1 2

8

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int f[210][1010];
void fib()         
{
     int i,j,a;
     f[0][0]=1;
     f[1][0]=1;
     for(i=2;i<=200;i++)
     {
     for(j=0;j<1000;j++)
     {
     a=f[i][j]+f[i-1][j]+f[i-2][j];
     f[i][j]=a%10;
     f[i][j+1]=f[i][j+1]+a/10;
     }
     }
}
int main()
{   
    fib();
    int n,len,i;
    char str[210];
    scanf("%d",&n);
    getchar();
    while(n--)
    {
         scanf("%s",str);
         getchar();
         len=strlen(str);
         if(len==0)
         printf("1\n");
         else if(len==1)
         printf("1\n");
         else
         {
         for(i=999;i>=0&&f[len][i]==0;i--) ;           
         for(;i>=0;i--)
         printf("%d",f[len][i]);
         printf("\n");
         }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值