【light oj】树的直径

Farthest Nodes in a Tree
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
#include <cstdio>  
#include <cstring>  
#include <queue>   
#include <algorithm>   
using namespace std;  
struct Edge  
{  
    int from, to, val, next;  
};  
Edge edge[60000+10];  
int head[30000+10];//头'指针' 
int edgenum;//边数  
int dist[30000+10];  //以该点为尾点的最长距离 
bool vis[30000+10];  
int node; //记录端点值 
int ans;  //最终的最长路径 
int n;  
int k = 1;  
void init()  //初始化 
{  
    edgenum = 0;  
    memset(head, -1, sizeof(head));  
}  
void addedge(int u, int v, int w)  
{  
    edge[edgenum].from = u;//起点 
    edge[edgenum].to = v;//终点 
    edge[edgenum].val = w;//权值 
    edge[edgenum].next = head[u];//指向下一条边 
    head[u] = edgenum++;  
}  
void BFS(int s)  
{  
    queue<int> q;  
    memset(dist, 0, sizeof(dist));  
    memset(vis, false, sizeof(vis));  
    vis[s] = true;  
    ans = 0;  
    node = s;  
    q.push(s);  
    while(!q.empty())  
    {  
        int u = q.front();  
       q.pop();  
        for(int i = head[u]; i != -1; i = edge[i].next)  //遍历每一条边 
        {  
           int v = edge[i].to;  
            if(!vis[v] && dist[v] < dist[u] + edge[i].val)  
            {  
                vis[v] = true;  
                dist[v] = dist[u] + edge[i].val;  
                if(dist[v] > ans)  
                {  
                    ans = dist[v];  
                    node = v;  
                }  
               q.push(v);  
            }  
        }  
    }  
}   
int main()  
{  
    int t;  
    scanf("%d", &t);  
    while(t--)  
    {  
        scanf("%d", &n);  
        init();  
         int a, b, c;  
    for(int i = 1; i < n; i++)  
    {  
        scanf("%d%d%d", &a, &b, &c);  
        //a++, b++;  
        addedge(a,b,c);  
        addedge(b,a,c);  
    }   
         BFS(1);  //①任意从一个点u出发bfs,设其能到的最远点为v,0不可以 
         BFS(node);  //②从v出发重新bfs,设其能到达的最远点为s
    printf("Case %d: %d\n", k++, ans);  
  
    }  
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值