【杭电1260】Tickets

Tickets
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am
题意:有K个人买票,可以每个人买单票,给出K个单买时间;也可以和前一个人买双票,给出K-1个买双票时间;
算出最少时间。
题解:依题意可以得出动态方程:dp[i]=min(dp[i-1]+one[i],dp[i-1]+two[i])
 
    
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
	int t,n,a[2001],b[2001],dp[2001];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);//人数
		for(int i=1;i<=n;i++)
		scanf("%d",&a[i]);//每个人单独买的价钱 
		for(int i=2;i<=n;i++)
		scanf("%d",&b[i]);//和前一个人一起买的价钱 
		dp[1]=a[1];dp[0]=0;
		for(int i=2;i<=n;i++)
			dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);//买一个人的或者买两个人的 
			int h=dp[n]/3600+8;
			int m=dp[n]/60%60;
			int s=dp[n]%60;
			if(h>12)
			printf("%02d:%02d:%02d pm\n",h,m,s);
			else
			printf("%02d:%02d:%02d am\n",h,m,s);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值