H - Tickets

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

题目大意:有n个人来买票,告诉你每个人来买票的时间,还有相邻两个一起买票的时间,问你如何买票能使买票的时间最少。

题解:要求出最小时间,就要比较,前n-1个人买票的最小时间加上自己买票的时间,和前n-2个人买票的最小时间加上第n个和第n-1个合买票的时间,看哪一个时间最小就去哪一个,状态转移方程:dp[n]=min(dp[n-1]+h[n],dp[n-2]+i[n-1]);

代码:

#include <iostream>
#include <bits/stdc++.h>

using namespace std;

const int MAXN = 2e3+7;

int h[MAXN],i[MAXN],dp[MAXN];

int main()
{
    int a,b,c,j,d,n,f,num;
    scanf("%d",&a);
    while(a--)
    {
        scanf("%d",&b);
        for(c=1;c<=b;c++)
        {
            scanf("%d",&h[c]);
        }
        for(c=1;c<=b-1;c++)
        {
            scanf("%d",&i[c]);
        }
        dp[0]=0;
        dp[1]=h[1];
        for(j=2;j<=b;j++)
        dp[j]=min(dp[j-2]+i[j-1],dp[j-1]+h[j]);
        num=dp[b]+8*3600;
        d=(num/3600);
        n=num/60%60;
        f=num%60;
        if(num>=12*3600)
        {
            printf("%02d:%02d:%02d pm\n",d>=13?d-12:d,n,f);
        }
        else
        {
            printf("%02d:%02d:%02d am\n",d,n,f);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值