***分解定理

G - G 使用long long
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

每个大于1的自然数均可写为质数的积,而且这些素因子按大小排列之后,写法仅有一种方式。

根据唯一分解定理,一个自然数可以写成质数的幂次方的乘积。例如10 = 2^1 * 5^1:
 
因为是尾部有Q个零,所以N!的结果中5的幂必须等于Q(此时,2的幂肯定比Q大)。
那么我们如果要求一个数的阶乘的结果5的幂次方是多少。
譬如30!的结果中,5的幂究竟是多少,答案是30/5 = 6, 6/5 = 1;结果为7个。其他数值也是这样求,除到最后的数<5为止。可以自己在纸上验证

不晓得这个定理难过

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
#include<cstdio>
long long s(long long n)//求n的阶乘中,末尾连续的0的个数
{
	long long ans=0;
	while(n)
	{
		ans+=n/5;
		n=n/5;
	}
	return ans;
} 
int main()
{
	int k=1;
	int t;
	long long q;
	scanf("%d",&t);
	while(t--)
	{
		
		scanf("%lld",&q);
		long long l=0,r=1e10;
		long long sum=0;
		while(l<=r)
		{
			long long mid=(l+r)/2;
			if(s(mid)==q)
			{
			sum=mid;
			r=mid-1;	
			}
			else if(s(mid)>q)
			r=mid-1;
			else
			l=mid+1;
		}
		printf("Case %d: ",k++);
		if(sum)
		printf("%lld\n",sum);
		else
		 printf("impossible\n"); 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值