杭电2266 How Many Equations Can You Find

 How Many Equations Can You Find
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output

The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input

123456789 3
21 1

Sample Output

18
1
深搜,计算每种可能情况的值
     
     
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
string s;
long n;
int cot;//方案数
long shu(int c,int e)//计算数值 
{
long sum=0;
	for(;c<=e;c++)
	sum=sum*10+s[c]-'0';
	return sum;
 }
 void dfs(int result,int c)//c表示字符位置 
 {
 	if(c>=s.length())//计算到字符串末尾 
 	{
 		if(result==n)
 		cot++;
	 }
	 else
	 {
	 for(int i=c;i<s.length();i++)
	 {
	 	dfs(result+shu(c,i),i+1);
	 	if(c!=0)//第一位前不能加- 
	 	dfs(result-shu(c,i),i+1);
		 }	
	 }
  }
  int main()
 {
 	while(cin>>s>>n)
 	{
 		cot=0;
 		dfs(0,0);
 		cout<<cot<<endl;
	 }
	 return 0;
  } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值