【杭电】5666 快乘

Segment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1803    Accepted Submission(s): 664


Problem Description
     Silen August does not like to talk with others.She like to find some interesting problems.

     Today she finds an interesting problem.She finds a segment x+y=q .The segment intersect the axis and produce a delta.She links some line between (0,0) and the node on the segment whose coordinate are integers.

     Please calculate how many nodes are in the delta and not on the segments,output answer mod P.
 

Input
     First line has a number,T,means testcase number.

     Then,each line has two integers q,P.

    q is a prime number,and 2q1018,1P1018,1T10.
 

Output
     Output 1 number to each testcase,answer mod P.
 

Sample Input
  
  
1 2 107
 

Sample Output
  
  
0
 

Source
直线x+y=q与坐标轴围成的三角形区域内有多少个整数点,x=1时,有q-2个整数点,x=2时,有q-3个.......以此类推最后有1个,所以一共有(q-2)*(q-1)/2个整数点
直接算会超时,所以用快乘法
code:
#include<cstdio>
#include<algorithm>
using namespace std;
long long kuaicheng(long long a,long long b,long long p){//计算a*b%p 快乘 
    long long ans=0;
    while(b){
        if(b%2!=0) ans=(ans+a)%p;
        a=(2*a)%p;
        b=b/2;
        }
        return ans;
    }
int main()
{
   int t;
   scanf("%d",&t);
   while(t--){
        long long n,p;
        scanf("%lld%lld",&n,&p);
    long long sum;
    if((n-1)%2==0)//为偶数 
    sum=kuaicheng((n-1)/2%p,(n-2)%p,p);
    else
    sum=kuaicheng((n-1)%p,(n-2)/2%p,p); 
    printf("%lld\n",sum%p);
        } 
    return 0;}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值