1080 Graduate Admission (30分)

121 篇文章 0 订阅
115 篇文章 0 订阅

It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​, and the interview grade G​I​​. The final grade of an applicant is (G​E​​+G​I​​)/2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​. If still tied, their ranks must be the same.

  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's G​E​​ and G​I​​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

作者: CHEN, Yue

单位: 浙江大学

时间限制: 250 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

 

题解:

第一次第四个测试点没过去

后来发现还是赋初值的问题,数据量大时不需要赋初值的数据不要随便赋值。能在一个if语句的不要在分else,否则很容易碰到难以测试的边界情况。

思路:考生按总成绩排序,排名靠前的学生优先选学校

考生一个结构体

学校一个结构体 {符合条件的考生加入到vector}。排名相同时 判断vector最后一个 .back()的数据

 

注意:感觉题干有一点比较模糊,报考同一个学校排名相同的考生同样要占学校名额引起 quote--

代码:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

struct Applicant
{
	int num, ge, gi, fg;
	int schools[5];
};

struct School
{
	int qupta;
	vector<Applicant> admited_stu;
};

Applicant applicants[40001];

bool cmp(Applicant a, Applicant b) {
	if (a.fg != b.fg) return a.fg > b.fg;
	else return a.ge > b.ge;
}
bool cmp2(Applicant a, Applicant b) {
	return a.num < b.num;
}

int main() {
	int n, m, k;
	cin >> n >> m >> k;
	vector<School> schools(m);
	for (int i = 0; i < m; i++)
	{
		cin >> schools[i].qupta;
	}

	for (int i = 0; i < n; i++)
	{
		applicants[i].num = i;
		cin >> applicants[i].ge >> applicants[i].gi;
		for (int j = 0; j < k; j++)
			cin >> applicants[i].schools[j];
		applicants[i].fg = applicants[i].ge + applicants[i].gi;
	}

	sort(applicants, applicants + n, cmp);

	for (int i = 0; i < n; i++)
	{
		for (int j = 0; j < k; j++)
		{
			int p = applicants[i].schools[j];
			if (schools[p].qupta > 0 || (!schools[p].admited_stu.empty() && schools[p].admited_stu.back().fg == applicants[i].fg &&schools[p].admited_stu.back().ge == applicants[i].ge)) {
				schools[p].admited_stu.push_back(applicants[i]);
				schools[p].qupta--;
				break;
			}
		}
	}
	for (int i = 0; i < m; i++)
	{
		sort(schools[i].admited_stu.begin(), schools[i].admited_stu.end(), cmp2);
	}

	for (int i = 0; i < m; i++)
	{
		if (schools[i].admited_stu.empty()) cout << '\n';
		else
		{
			for (int j = 0; j < schools[i].admited_stu.size(); j++)
			{
				if (j == 0) cout << schools[i].admited_stu[j].num;
				else
					cout << ' ' << schools[i].admited_stu[j].num;
			}
			cout << '\n';
		}
	}
    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值