7-2 Block Reversing (25分) 【PAT 甲级19年冬考】

121 篇文章 0 订阅
115 篇文章 0 订阅

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:

71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1

 

题解:

最后一个点不知道哪里有问题···

 

感谢评论区大佬提醒,知道哪里的问题了,第六个测试点可能会有脏数据。

访问Vector 时要用v.size().不要直接用n

做PAT 的题目要非常细心与耐心 QAQ。临近考试才彻底感受到不认真刷题的后果ORZ

 

代码已修改:

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

const int N = 1e6 + 10;

int head, n, k;
int e[N], ne[N];

int main() {

	cin >> head >> n >> k;
	for (int i = 0; i < n; i++)
	{
		int add, key, next;
		cin >> add >> key >> next;
		e[add] = key;
		ne[add] = next;
	}

	vector<int> v;

	for (int i = head; i != -1; i = ne[i])
		v.push_back(i);

	reverse(v.begin(), v.end());

	int m = n % k;
	reverse(v.begin(), v.begin() + m); 
// 传入逆置得起点下标和逆置得终点下标的后一个,类似v.end
	for (int i = m; i + k - 1 < v.size(); i += k)
		reverse(v.begin() + i, v.begin() + i + k);

	ne[v[v.size() - 1]] = -1;
	for (int i = 0; i < v.size() - 1; i++)
		ne[v[i]] = v[i + 1];

	for (int i = 0; i < v.size(); i++) {
		if (i != v.size() - 1)
			printf("%05d %d %05d\n", v[i], e[v[i]], ne[v[i]]);
		else
			printf("%05d %d -1\n", v[i], e[v[i]]);
	}

	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值