Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (≤104), the number of records, and K (≤8×104) the number of queries. Then N lines follow, each gives a record in the format:
plate_number hh:mm:ss status
where plate_number
is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss
represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00
and the latest 23:59:59
; and status
is either in
or out
.
Note that all times will be within a single day. Each in
record is paired with the chronologically next record for the same car provided it is an out
record. Any in
records that are not paired with an out
record are ignored, as are out
records not paired with an in
record. It is guaranteed that at least one car is well paired in the input, and no car is both in
and out
at the same moment. Times are recorded using a 24-hour clock.
Then K lines of queries follow, each gives a time point in the format hh:mm:ss
. Note: the queries are given in ascending order of the times.
Output Specification:
For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.
Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09
作者: CHEN, Yue
单位: 浙江大学
时间限制: 300 ms
内存限制: 64 MB
题解:
一开始没想出来,看了别人的题解。
一开始有几个迷惑我的地方:
1.正确数据选择,in,out 若果不匹配,应该选择哪一个in 或 out(题目没明说,需要自己分析数据,数据又太乱了不好分析····)
实际题目要求:对同一辆车按时间顺序排好 如果前面有多个in 选择最后一个,如果后面有多个out选择第一个。
2.感觉一个数组不够,而且需要开很多其他辅助的数据结构
3.答案是多次查询,感觉肯定会超时
之后就没敢往下写,直接看题解了
#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;
struct Record
{
string plate;
int hh, mm, ss, status, fulltime;
};
Record records[10001];
bool cmp1(Record a, Record b) {
if (a.plate != b.plate) return a.plate < b.plate;
else return a.fulltime < b.fulltime;
}
bool cmp2(Record a, Record b) {
return a.fulltime < b.fulltime;
}
int main() {
vector<Record> car;
map<string, int> pmap;
int n, k, maxtime = -1;
cin >> n >> k;
for (int i = 0; i < n; i++)
{
string s;
cin >> records[i].plate;
scanf("%d:%d:%d", &records[i].hh, &records[i].mm, &records[i].ss);
cin >> s;
records[i].status = (s == "in" ? 1 : -1);
records[i].fulltime = records[i].hh * 60 * 60 + records[i].mm * 60 + records[i].ss;
}
sort(records, records + n, cmp1);
for (int i = 0; i < n - 1; i++)
{
if (records[i].plate == records[i + 1].plate && records[i].status == 1 && records[i + 1].status == -1)
{
car.push_back(records[i]);
car.push_back(records[i + 1]);
pmap[records[i].plate] += (records[i + 1].fulltime - records[i].fulltime);
if (maxtime < pmap[records[i].plate])
maxtime = pmap[records[i].plate];
}
}
sort(car.begin(), car.end(), cmp2);
vector<int> cnt(n);
for (int i = 0; i < car.size(); i++)
{
if (i == 0) cnt[i] += car[i].status;
else cnt[i] = cnt[i - 1] + car[i].status;
}
int index = 0;
for (int i = 0; i < k; i++)
{
int h, m, s, temptime;
scanf("%d:%d:%d", &h, &m, &s);
temptime = h * 3600 + m * 60 + s;
int j;
for (j = index; j < car.size(); j++)
{
if (car[j].fulltime > temptime)
{
cout << cnt[j - 1] << '\n';
break;
}
else if (j == car.size() - 1)
cout << cnt[j] << '\n';
}
index = j;
}
for (map<string, int>::iterator it = pmap.begin(); it != pmap.end(); it++)
{
if (it->second == maxtime)
cout << it->first << ' ';
}
printf("%02d:%02d:%02d", maxtime / 3600, (maxtime % 3600) / 60, maxtime % 60);
return 0;
}