Building a Space Station

Building a Space Station

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor’, or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells’ surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.

Input

The input consists of multiple data sets. Each data set is given in the following format.

n
x1 y1 z1 r1
x2 y2 z2 r2

xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

题目大意

对于 n 个空间站,输入坐标(x,y,z)以及半径 r(空间站视为球体),现在要在空间站之间连接通道,最终使左右的空间站相通,求可以建立的最短通道,空间站接触或者相交时需要建立的通道距离为 0

分析

对于空间站的距离,不难写出为d-r1-r2,其中 d 为球心间距,r 为空间站半径,在此结果不大于 0 时通道的长度为为 0,在此基础上成为了最小生成树问题(边权之和在所有满足条件的情况中最小,权值为空间站间距),用到Kruskal算法来找最小生成树,这里推荐 b 站上一个有趣易懂的讲解视频:
最小生成树(Kruskal(克鲁斯卡尔)和Prim(普里姆))算法动画演示(时长 9 分钟)

代码实现

/*图的kruskal算法 最小生成树*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 110;
int uset[maxn];//父母
int n, cnt;
struct cell {
	double x, y, z, r;
}q[maxn];
struct edge {
	int s, e;//边的两端点编号
	double w;//卫星间距
}E[maxn * maxn];
bool cmp(edge a, edge b) {
	return a.w < b.w;//排序规则:权值从小到大
}
double between(cell a, cell b) {
	double dis;
	dis = sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y) + (a.z - b.z) * (a.z - b.z)) - a.r - b.r;
	if (dis <= 0) return 0;//不用建立通道
	return dis;
}
int find(int x) {//并查集思想:找根节点
	return x == uset[x] ? x : uset[x] = find(uset[x]);
}
bool link(int x, int y) {//表示空间站相交(不用建立通道)
	int fx, fy;
	fx = find(x);
	fy = find(y);
	if (fx == fy) return false;
	uset[fy] = fx;
	return true;
}
void Kruskal() {//最小生成树
	int i, j, k;
	sort(E + 1, E + 1 + cnt, cmp);
	for (i = 1;i <= n;i++) uset[i] = i;
	double sum = 0.0;
	int ct = 0;
	for (i = 1;i <= cnt;i++) {
		if (link(E[i].s, E[i].e)) {
			sum += E[i].w;
			ct++;//记录以使用的边的个数(最大 n-1)
			if (ct == n - 1) break;
		}
	}
	printf("%.3lf\n", sum);
	return;
}
int main() {
	while (scanf("%d", &n) && (int)n) {
		int i, j;
		cnt = 0;
		for (i = 1;i <= n;i++) {
			cin >> q[i].x >> q[i].y >> q[i].z >> q[i].r;
			for (j = 1;j < i;j++) {
				double dis;
				dis = between(q[j], q[i]);
				E[++cnt].s = j;
				E[cnt].e = i;
				E[cnt].w = dis;
			}
		}
		Kruskal();
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值