Building a Space Station (Kruskal)

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task.
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible.

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively.

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors.

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect.
Input
The input consists of multiple data sets. Each data set is given in the following format.

n
x1 y1 z1 r1
x2 y2 z2 r2
...
xn yn zn rn

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100.

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character.

Each of x, y, z and r is positive and is less than 100.0.

The end of the input is indicated by a line containing a zero.
Output
For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001.

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000.
Sample Input
3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0
Sample Output
20.000
0.000
73.834








 

题意:

假设你是太空工作站的一员,现在安排你去完成一个任务:在N个小空间站(为球形)之间修路使他们能够互通,要求修路的长度要最小

如果两个空间站紧挨在一起,则不需要修路

多组数据输入

第一行  一个数字N 表示有N个子空间站

第2---N+1行   每行4个数据,前3个为空间站的球心,第4个为半径

思路:

很明显是最小生成树问题

但关键是如何找到边关系,我们可以找一个数组num存放空间站信息(球心坐标和半径)

每输入一个新空间站信息时,把它和之前存过的空间站相连,求出要修路的长度,

由于每两个空间站在num数组里的不同位置,所以在num数组的序号可以看成 两个点,

将这两点以及要修路的长度看成一条边的信息存放到到一个数组中

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int n,pre[110];
struct node{    //存放边关系
    int u,v;
    double w;
}e[100010];
struct node1{   //存放每个细胞球心的坐标,半径
    double x,y,z,r;
}num[110];
int cmp(node a,node b){
    return a.w<b.w;
}
int Find(int x){
    int r=x;         
    while(r!=pre[r])   //寻找根结点
        r=pre[r];
    int i=x,j;
    while(i!=r){       //压缩路径
        j=pre[i];
        pre[i]=r;
        i=j;
    }
    return r;
}
int mix(int a,int b){
    int fa=Find(a),fb=Find(b);   //寻找父节点,判断以a b为端点的线段是否已经加入
    if(fa!=fb){
        pre[fb]=fa;
        return 1;
    }
    return 0;
}
void init(){        //初始化pre数组
    int i;
    for(i=0;i<=n;i++)
        pre[i]=i;
}
int main(){
    while(scanf("%d",&n)!=EOF){
        if(n==0) break;
        int t=0;
        int i,j;
        for(i=0;i<n;i++){
            scanf("%lf%lf%lf%lf",&num[i].x,&num[i].y,&num[i].z,&num[i].r); //输入细胞的信息
            for(j=0;j<i;j++){
                double s1=(num[i].x-num[j].x)*(num[i].x-num[j].x);
                double s2=(num[i].y-num[j].y)*(num[i].y-num[j].y);
                double s3=(num[i].z-num[j].z)*(num[i].z-num[j].z);
                double R=sqrt(s1+s2+s3)-(num[i].r+num[j].r);       //求出两个细胞需要修路的长度
                e[t].u=i;        //由于每两个点在num数组里的不同位置,所以在num数组的序号可以看成 两个点
                e[t].v=j;
                e[t++].w=R;   
            }
        }
        sort(e,e+t,cmp);  //按从小到大排序
        init();
        int countt=0;  //记录加入边的条数
        double sum=0;  //记录总距离
        for(i=0;i<t;i++){
            if(mix(e[i].u,e[i].v)){  //如果两点组成的边不在树里则加入
                if(e[i].w>0) sum+=e[i].w; //注意:如果两细胞挨着,需要修路的半径会为负数,则不需修路
                countt++;
            }
            if(countt==n-1) break;  //当加入到边数比顶点数少一,则形成一个树,直接跳出循环
        }
        printf("%.3f\n",sum);
    }
return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值