kuangbin专题四-Frogger(最短路)

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:这个英语说实话,我看翻译着实没看懂,看别人的题解才看懂这个题意,主要说的是:n个石头,石头之间的最小跳距离为
先求:石头之间所有路径中最大的那个边
之后:最大的这些边中最小的那个 就是石头之间的最小跳距离,两只青蛙的坐标为第一个和第二个。
思路:先用x,y数组来存一个坐标的x,y值,然后存地图,G[i][j]就是地图上从i到j的距离,两点之间的距离为(x1-x2)2+(y1-y2)2再开根号。
最短路dij算法:初始化dis数组为无穷大,主要记录的是从1-每一个石头之间的最小跳距离,vis数组标记这个石头是否找到它的答案,有n个石头,循环n次,找完每一个石头。每次循环找还没有被标记过的石头中,dis最小的那个为k点,然后标记。
更新:更新dis数组,通过k点到达j点中,这条路径中找到比较大的那个边,然后这条边再与目前j点所确定的最小跳距离比较,小的那个为j点的最小跳距离。
最后两个青蛙为坐标1到2的最小跳距离,即为dis[2]。
代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<map>
using namespace std;
const int N=2000;
const int INF=0x3f3f3f3f;//无穷大
int n;
int x[N];//x坐标
int y[N];//y坐标
double G[N][N];//地图
double dis[N];//1-其他石头的最小跳距离
bool vis[N];//这个石头是否已经被找过
void dij ()
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++){
        dis[i]=INF;//初始化
    }
    dis[1]=0;//标记
    for(int i=1;i<=n;i++){
        int minn=INF,k;
        for(int j=1;j<=n;j++){
            if(vis[j]==0&&dis[j]<minn){//寻找最小的那个dis且未被找过
                minn=dis[j];
                k=j;
            }
        }
        vis[k]=1;
        for(int j=1;j<=n;j++){
            dis[j]=min(dis[j],max(dis[k],G[k][j]));//更新
        }
    }
}
int main ()
{
    ios::sync_with_stdio(false);
    int sum=0;
    while(cin>>n&&n!=0){
        memset(G,0,sizeof(G));
        for(int i=1;i<=n;i++){
            cin>>x[i]>>y[i];
        }
        for(int i=1;i<=n;i++){
            for(int j=i+1;j<=n;j++){
                G[i][j]=G[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));//存图
            }
        }
        dij();
        sum++;
        printf("Scenario #%d\n",sum);
        printf("Frog Distance = %.3lf\n\n",dis[2]);//输出,有坑\n\n
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值