UVa 10285 Longest Run on a Snowboard(DP)

本文介绍了一道名为'Longest Run on a Snowboard'的问题,旨在找到给定高度网格中的最长递减连续序列。通过动态规划方法(DP)来解决,定义d[i][j]为以坐标(i,j)开始的最长序列长度,状态转移方程为d[i][j]=max{d[a][b]}+1,其中a,b是与i,j相邻且高度小于i,j的所有点。" 12418525,966797,Struts2 实现过滤器Filter详解,"['Struts2框架', '过滤器开发', '字符编码处理']
摘要由CSDN通过智能技术生成

Longest Run on a Snowboard

Input: standard input

Output: standard output

Time Limit: 5 seconds

Memory Limit: 32 MB

 

Michael likes snowboarding. That's not very surprising, since snowboarding is really great. The bad thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when you've reached the bottom of the hill you have to walk up again or wait for the ski-lift.

Michael would like to know how long the longest run in an area is. That area is given by a grid of numbers, defining the heights at those points. Look at this example:

 1  2  3  4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

One can slide down from one point to a connected other one if and only if the height decreases. One point is connected to another if it's at left, at right, above or below it. In the sample map, a possible slide would be 24-17-16-1 (start at 24, end at1). Of course if you would go 25-24-23-...-3-2-1, it would be a much longer run. In fact, it's the longest possible.

Input

The first line contains the number of test cases N. Each test case starts with a line containing the name (it's a single string), the number of rows R and the number of columns C. After that follow R lines with C numbers each, defining the heights. Rand C won't be bigger than 100N not bigger than 15 and the heights are always in the range from 0 to 100.

For each test case, print a line containing the name of the area, a colon, a space and the length of the longest run one can slide down in that area.

Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

 

Sample Output

Feldberg: 7
Spiral: 25


题意:在一个矩阵中找出最长递减连续序列,也是较基础的dp,令d[i][j]为以格子map(i,j)为起点的最长序列

则有状态转移方程d[i][j]=max{d[a][b]}+1  a,b为与i,j相邻且值比i,j小的所有点;

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 105
#define a i+x[k]
#define b j+y[k]
int ma[maxn][maxn],d[maxn][maxn],r,c,n,ans;
int x[4]={0,0,1,-1},y[4]={-1,1,0,0};

int dp(int i,int j)
{
    if(d[i][j]>0) return d[i][j];
    d[i][j]=1;
    for(int k=0;k<4;++k)
    if((ma[i][j]>ma[a][b])&&(a>0&&a<=r)&&(b>0&&b<=c))
    {
        d[i][j]=max(d[i][j],dp(a,b)+1);
    }
    return d[i][j];
}

int main()
{
    char name[100];
    scanf("%d",&n);
    for(int cas=1;cas<=n;++cas)
    {
        scanf("%s%d%d",name,&r,&c);
        for(int i=1;i<=r;++i)
            for(int j=1;j<=c;++j)
                scanf("%d",&ma[i][j]);

        memset(d,0,sizeof(d));
        ans=0;
        for(int i=1;i<=r;++i)
            for(int j=1;j<=c;++j)
                ans=max(dp(i,j),ans);

        printf("%s: %d\n",name,ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
As an AI language model, I cannot provide you with the exact solution you need without further details. However, here is a general approach to find the longest distance in a binary tree using Python: 1. Define a class for a binary tree node with attributes for the node value, left child, and right child. 2. Define a function that recursively traverses the binary tree and returns the height of the tree starting from a given node. 3. Define a function that recursively traverses the binary tree and returns the longest distance between two nodes in the tree. 4. In the function defined in step 3, for each node, calculate the longest distance that passes through that node and update the maximum distance seen so far. 5. Call the function defined in step 3 starting from the root node of the binary tree. Here is a sample implementation of the above approach: ``` class Node: def __init__(self, value): self.value = value self.left = None self.right = None def height(root): if root is None: return 0 return 1 + max(height(root.left), height(root.right)) def longest_distance(root): if root is None: return 0 left_height = height(root.left) right_height = height(root.right) left_distance = longest_distance(root.left) right_distance = longest_distance(root.right) return max(left_height + right_height, max(left_distance, right_distance)) root = Node(1) root.left = Node(2) root.right = Node(3) root.left.left = Node(4) root.left.right = Node(5) root.right.left = Node(6) root.right.right = Node(7) print(longest_distance(root)) ``` This code will output the longest distance between any two nodes in the binary tree.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值