Problem F: 类的运算符

Problem F: 类的运算符

Description
设计一个复数类Cx,满足“Append Code”,完成程序。

Cx类由实部和虚部组成,需要定义类的构造函数,并且在类上重载运算符“+=”。

Input
输入为两个整数。
Output
见样例。

Sample Input
1 2
Sample Output
(1,2)

Append Code

int main()
{
    int a, b;    
    cin >> a >> b;    
    Cx c, cc(a, b);    
    c += cc;    
    c.print();
}

code:

#include <iostream>
using namespace std;
class Cx{    
    int a;    
    int b;public:    
    Cx(){a=0;b=0;}    
    Cx(int aa,int bb):a(aa),b(bb){}    
    void print()    
    {        
    cout<<"("<<a<<","<<b<<")";    
    }    
    Cx &operator+=(Cx &c)    
    {        
        a=c.a+a;        
        b=c.b+b;       
        return *this;   
   }
};
int main()
{
    int a, b;    
    cin >> a >> b;    
    Cx c, cc(a, b);    
    c += cc;    
    c.print();
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值