Swap

Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?

Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.
Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”.
Sample Input
2
0 1
1 0
2
1 0
1 0
Sample Output
1
R 1 2
-1
题意:

通过对换矩阵的两行或两列使得矩阵的主对角线上的元素均为1

思路

二分图的最大匹配

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	int a,b;
}op[1010];
const int N = 110;
int match[N],used[N];
int e[N][N];
int n;
int Find(int x){
	for(int i=1;i<=n;i++){
		if(e[x][i]&&!used[i]){
			used[i]=1;
			if(!match[i]||Find(match[i])){
				match[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int hungary(){
	memset(match,0,sizeof(match));
	int ans=0;
	for(int i=1;i<=n;i++){
		memset(used,0,sizeof(used));
		if(Find(i)) ans++;
	}
	return ans;
}
int main(){
	while(scanf("%d",&n)!=EOF){
		for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
		scanf("%d",&e[i][j]);
		int ans=hungary();
		if(ans<n){
			printf("-1\n");
			continue;
		}
		int cnt=0;
        for(int i=1;i<=n;i++){
        	int j;
        	for(j=1;j<=n;j++){
        		if(match[j]==i) break;
			}
			if(j!=i){
				op[cnt].a=i;
				op[cnt++].b=j;
				swap(match[i],match[j]);
			}
		}
		printf("%d\n",cnt);
		for(int i=0;i<cnt;i++)
		printf("C %d %d\n",op[i].a,op[i].b);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值