Catch(HDU2478)

Problem Description
A thief is running away!
We can consider the city where he locates as an undirected graph in which nodes stand for crosses and edges stand for streets. The crosses are labeled from 0 to N–1.
The tricky thief starts his escaping from cross S. Each moment he moves to an adjacent cross. More exactly, assume he is at cross u at the moment t. He may appear at cross v at moment t + 1 if and only if there is a street between cross u and cross v. Notice that he may not stay at the same cross in two consecutive moment.
The cops want to know if there’s some moment at which it’s possible for the thief to appear at any cross in the city.
 

Input
The input contains multiple test cases:
In the first line of the input there’s an integer T which is the number of test cases. Then the description of T test cases will be given.
For any test case, the first line contains three integers N (≤ 100 000), M (≤ 500 000), and S. N is the number of crosses. M is the number of streets and S is the index of the cross where the thief starts his escaping.
For the next M lines, there will be 2 integers u and v in each line (0 ≤ u, v < N). It means there’s an undirected street between cross u and cross v.

 

Output
For each test case, output one line to tell if there’s a moment that it’s possible for the thief to appear at any cross. Look at the sample output for output format.

 

Sample Input
  
  
2 3 3 0 0 1 0 2 1 2 2 1 0 0 1
 

Sample Output
 
 
Case 1: YES Case 2: NO
Hint
For the first case, just look at the table below. (YES means the thief may appear at the cross at that moment)
For the second input, at any moment, there’s at least one cross that the thief can’t reach.

题意:给一个无向图和小偷所在的起点,小偷每秒可以向相连的点出发,警察想知道会不会存在一个时间点小偷出现在每个点都有可能。

思路:画几个图可以发现,图不连通的时候,必定是NO。如果图连通,会发现小偷的移动就是二分图的A部和B部在交替,而如果图不是一个二分图,那么小偷就能通过奇数环(二分图的环都是偶环),让两部的点混合导致可以同时出现。即当图不是二分图且是连通图时YES,否则NO,染色法二分图 的判定与染色起点无关。

代码:

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
const int N = 100005;
vector<int>G[N];
int col[N];
void init(int n){
	for(int i=0;i<=n;i++)
	   G[i].clear();
}
int Dfs(int x,int color){
	col[x]=color;
	for(int i=0;i<G[x].size();i++){
		int u=G[x][i];
		if(col[u]==color) return 0;
		if(!col[u]&&!Dfs(u,-color)) return 0;
	}
	return 1;
}
void work(int n){
	memset(col,0,sizeof(col));
	int flag=0,cnt=0;
    for(int i=0;i<n;i++){
    	if(!col[i]){
    		cnt++;
    		if(!Dfs(i,1)){
    			flag=1;
    			break;
			}
		}
	}
	if(flag) printf("YES\n");
	else if(cnt>1) printf("NO\n");
	else printf("NO\n");
}
int main(){
	int T;
	scanf("%d",&T);
	int Case=0;
	while(T--){
		int n,m,s;
		scanf("%d%d%d",&n,&m,&s);
		init(n);
		for(int i=0;i<m;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			G[a].push_back(b);
			G[b].push_back(a);
		}
		printf("Case %d: ",++Case);
		work(n);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值