hdu 2478||3090 欧拉函数

Farey Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 0 Accepted: 0

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

code:完整的注释部分是另一种求解

#include <iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
using namespace std;

const int size=1000005;
bool ok[size];
int ph[size];
int prime[size];
__int64 sum[size];
int pn;
int n;
//void getph()
//{
//    int i,j;
//    pn=0;
//    for(i=2;i<size;i++)
//    {
//        if(!ok[i])
//        {
//            prime[pn++]=i;
//            ph[i]=i-1;
//        }
//        for(j=0;(j<pn)&&(i*prime[j]<size);j++)
//        {
//            ok[i*prime[j]]=1;
//            if((i%prime[j])==0)
//            {
//                ph[i*prime[j]]=ph[i]*prime[j];
//                break;
//            }
//            else
//                ph[i*prime[j]]=ph[i]*(prime[j]-1);
//
//        }
//    }
//}
void Euler()
{
       int i,j;
       memset(ph,0,sizeof(ph));
       for(i=2;i<=1000002;i++)
       {
                     if(!ph[i])
                     {
                            for(j=i;j<1000002;j+=i)
                            {
                                   if(!ph[j]) ph[j]=j;
                                   ph[j]=(ph[j]/i)*(i-1);
                            }
                     }
       }
}
int main()
{
    ph[1]=1;
   // getph();
   Euler();
    for(int i=2;i<size;i++)
        sum[i]=sum[i-1]+ph[i];
    while(scanf("%d",&n)!=EOF&&(n!=0))
        printf("%I64d\n",sum[n]);
    return 0;
}




Visible Lattice Points
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6113 Accepted: 641

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

思路  转 :先画一条(0, 0)到(n, n)的线,把图分成两部分,两部分是对称的,只需算一部分就好。
取右下半,这一半里的点(x, y)满足x >= y
可以通过欧拉函数计算第k列有多少点能够连到(0, 0)
若x与k的最大公约数d > 1,则(0, 0)与(x, k)点的连线必定会通过(x/d, k/d),就被挡住了
所以能连的线的数目就是比k小的、和k互质的数的个数,然后就是欧拉函数。

code:

#include<stdio.h>
#include<math.h>
int euler(int x)
{
    int i, res=x,tmp;
    tmp=(int)sqrt(x * 1.0) + 1;
    for (i = 2; i <tmp; i++)
        if(x%i==0)
        {
            res = res / i * (i - 1);
            while (x % i == 0) x /= i;
        }
    if (x > 1)
        res = res / x * (x - 1);
	return res;
}

int main()
{
        int test,n,i,ans,_case=1;
	scanf("%d",&test);
	while(test--)
	{
		ans=0;
		scanf("%d",&n);
		for(i=2;i<=n;i++)//cong 2 kaishi
			ans+=euler(i);
		printf("%d %d %d\n",_case++,n,ans*2+3);//di yi lie you 2 ge ,zhongjian you yige
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值