Substrings HDU - 1238

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
Output
There should be one line per test case containing the length of the largest string found.
Sample Input
2
3
ABCD
BCDFF
BRCD
2
rose
orchid
Sample Output
2
2
求所有字符串的最长公共字符串或者逆序字符串的长度
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N = 105;
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int n;
		scanf("%d",&n);
		char str[N][N];
		int minLen=N;
		int mint=0;
		for(int i=0;i<n;i++){
			scanf("%s",str[i]);
			int len=strlen(str[i]);
			if(minLen>len){
				minLen=len;
				mint=i;
			}
		}
        int maxt=0;
        for(int i=0;i<minLen;i++){//子串的起点 
        	for(int j=i;j<minLen;j++){//子串的终点
        		char str1[N],str2[N];
        		for(int k=i;k<=j;k++){
        			str1[k-i]=str[mint][k];//正序串 
        			str2[j-k]=str[mint][k];//逆序串 
				}
				str1[j-i+1]=str2[j-i+1]='\0';
				int len=strlen(str1);
				int flag=1;
				for(int k=0;k<n;k++){
					if(!strstr(str[k],str1)&&!strstr(str[k],str2)){
						flag=0;
						break;
					}
				}
				if(flag) maxt=max(maxt,len);
			}
		}
		printf("%d\n",maxt);
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值