最长对称子串(马拉车算法)

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定"Is PAT&TAP symmetric?",最长对称子串为"s PAT&TAP s",于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:
Is PAT&TAP symmetric?
输出样例:
11

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<string.h>
using namespace std;
const int N = 1005;
int Manacher(char* s){
	string t="$#";
	for(int i=0;i<strlen(s);i++){
		t+=s[i];
		t+="#";
	}
	vector<int>p(t.size(),0);
	int mx=0,id=0,resLen=0,resCenter=0;
	for(int i=1;i<t.size();i++){
		p[i]=mx>i?min(p[2*id-i],mx-i):1;
		while(t[i+p[i]]==t[i-p[i]]) ++p[i];
		if(mx<i+p[i]){
			mx=i+p[i];
			id=i;
		}
		if(resLen<p[i]){
			resLen=p[i];
			resCenter=i;
		}
	}
	return resLen-1;
}
int main(){
	char str[N];
	gets(str);
	printf("%d\n",Manacher(str));
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值