HDU-2698 Maximum Multiple(规律)

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

 

 

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

 

 

Sample Input

 

3 1 2 3

 

 

Sample Output

 

-1 -1 1

题意:找一组x,y,z,输出x*y*z最大值,且满足x+y+z=n x,y,z均能整除n

思路:

打表找规律

打表代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int n;
		//scanf("%d",&n);
		for(int n=1;n<=100;n++){
			int maxt=-1;
			int a,b,c;
			for(int x=1;x<=n;x++){
				for(int y=1;y<=n-x;y++){
					int z=n-x-y;
					if(z&&n%x==0&&n%y==0&&n%z==0){
						if(maxt<x*y*z){
							a=x;
							b=y;
							c=z;
						}maxt=max(maxt,x*y*z);
					}
					   
				}
			}
			printf("%d:%5d %d %d %d\n",n,maxt,a,b,c);
			if(n%12==0) printf("\n");
		}
	}
	return 0;
}

正解代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
int judge(LL x){
	return x%12==1||x%12==2||x%12==5||x%12==7
	       ||x%12==10||x%12==11;
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		LL n;
		scanf("%lld",&n);
	    if(judge(n)) printf("-1\n");
	    else{
	   	    LL x,y,z;
	   	    if(n%3==0) x=y=z=n/3;
	   	    else{
	   	        x=n/2;
			   	y=z=x/2;
			}
			printf("%lld\n",x*y*z);
	   }
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值