Maximum Multiple(最大倍数)

题目链接
Maximum Multiple
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1535 Accepted Submission(s): 669

Problem Description
Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output
For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input
3
1
2
3

Sample Output
-1
-1
1

题意解析:
给出一个n,求x,y,z,使得x+y+z=n,且x,y,z,都是n的因子(x|n,y|n,z|n),输出此时的x,y,z,的乘积即可。
解题思路:
总的解题思路就是,按照题意写出常规代码,输出全部结果,然后找规律,找到规律是三和四的倍数,然后对应处理输出即可。
注意:
刚开始做的时候,虽然找到规律了,但是还是过不了,因为超时,但是始终找不到错误点,最后把cin cout改成scanf printf过了……
代码篇:

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    long long int t,n;
    while(~scanf("%lld",&t))
    {
        while(t--)
        {
            scanf("%lld",&n);
            if(n%3==0)
                printf("%lld\n",(n/3)*(n/3)*(n/3));
            else if(n%4==0)
                printf("%lld\n",(n/4)*(n/4)*(n/2));
            else
                printf("-1\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值