poj 1007 DNA Sorting java版

原题如下:
DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 70970 Accepted: 28300
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
Source

East Central North America 1998

我的java程序如下:
import java.util.Scanner;

public class Main{
public static void main(String args[]){
Scanner cin = new Scanner(System.in);
int numOfChars = cin.nextInt();
int numOfStrings = cin.nextInt();
cin.nextLine();
String strings[] = new String[numOfStrings];
int degrees[] = new int[numOfStrings];//存储每个字符串的sortedness
for(int i = 0; i < numOfStrings; i++){//求得每个字符串的sortedness,并存储在数组degrees[]中
degrees[i] = 0;
strings[i] = cin.nextLine();
for(int j = 0; j < numOfChars; j++){
if(strings[i].charAt(j) == 'A'){//如果当前字符是A,后面不管是什么字符,sortedness都不变

}else if (strings[i].charAt(j) == 'C'){//如果当前字符是C,后面若有A,则sortedness+1
for(int k = j+1; k < numOfChars; k++){
if(strings[i].charAt(k) == 'A'){
degrees[i]++;
}
}
}else if (strings[i].charAt(j) == 'G'){//如果当前字符是G,后面若有A或C,则sortedness+1
for(int k = j+1; k < numOfChars; k++){
if(strings[i].charAt(k) == 'A'|| strings[i].charAt(k) == 'C'){
degrees[i]++;
}
}
}else{//若当前字符是T,后面有几个非T的字符,sortedness就加几
for(int k = j+1; k < numOfChars; k++){
if(strings[i].charAt(k) != 'T'){
degrees[i]++;
}
}
}
}
//System.out.println(degrees[i]);
}//outer for
int minIndex = 0;
for(int i = 0; i < numOfStrings; i++){
int min = Integer.MAX_VALUE;
for(int j = i; j < numOfStrings; j++){
if(degrees[j] < min){
min = degrees[j];
minIndex = j;
}
}
System.out.println(strings[minIndex]);
int tmp = degrees[i];
degrees[i] = degrees[minIndex];
degrees[minIndex] = tmp;
String tmpString = strings[i];
strings[i] = strings[minIndex];
strings[minIndex] = tmpString;
}



}//main

}


忘各位朋友多多指教!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值