POJ 2559 Largest Rectangle in a Histogram -- 动态规划

题目地址:http://poj.org/problem?id=2559

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000


如果确定了长方形的左端点L和右端点R,那么最大可能的高度就是min{hi|L <= i < R}。

L[i] = (j <= i并且h[j-1] < h[i]的最大的j)

R[i] = (j > i并且h[j] > h[i]的最小的j)


#include <stdio.h>

#define MAX_N 100000

int n;
int h[MAX_N];
int L[MAX_N], R[MAX_N];
int stack[MAX_N];

long long max(long long a, long long b){
	return (a > b) ? a : b;
}

void solve(){
	//计算L
	long long ans = 0;
	int t = 0;
	int i;
	for (i = 0; i < n; ++i){
		while (t > 0 && h[stack[t-1]] >= h[i]) t--;
		L[i] = (t == 0) ? 0 : (stack[t-1] + 1);
		stack[t++] = i;
	}

	//计算R
	t = 0;
	for (i = n - 1; i >= 0; --i){
		while (t > 0 && h[stack[t-1]] >= h[i]) t--;
		R[i] = (t == 0) ? n : stack[t-1];
		stack[t++] = i;
	}

	for (i = 0; i < n; ++i){
		ans = max(ans, (long long)h[i] * (R[i] - L[i]));
	}
	printf("%lld\n", ans);
}

int main(void){
	int i;
	while (scanf("%d", &n) != EOF && n != 0){
		for (i = 0; i < n; ++i)
			scanf("%d", &h[i]);
		solve();
	}

	return 0;
}

参考资料: 挑战程序设计竞赛(第2版)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值