hdu 1026 Ignatius and the Princess I

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4313    Accepted Submission(s): 1348
Special Judge

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

 

Sample Input
 
 
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.

 

Sample Output
 
 
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
      该题的难点就是:如何记录以最短时间到达目标的路径,并输出它每一秒的状态。解决这个问题,要用到优先队列和栈!!!
要注意一下几点:
1.因为他要最短时间到达,所以要用到优先队列,时间短的先作处理;
2.因为要记录到达目标的路径,所以要开个map[][]2维数组来保存他之前来的那个坐标;
3.最后,你要从目标倒推到起点,并从起点的坐标开始输出到目标的路径,这个就要用的栈了。
我的代码(有注释):
#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <queue>
#include <stack>
using namespace std;

int xx[4] = {1, -1, 0, 0};
int yy[4] = {0, 0, -1, 1};

int nn, mm;
char a[105][105];
int map[105][105];
bool flag;

struct node
{
    friend bool operator < (node a, node b)
    {
        return a.time > b.time; //时间短的优先
    }
    int x, y, time;
    int px, py;         //px,py是保存上一点的记录
}n, m, ch[105][105];    //ch数组代表每一个坐标

int main()
{
    int i, j, ant;
    while(scanf("%d %d", &nn, &mm) != EOF)
    {
        for(i = 0; i < nn; i++)
        {
            getchar();
            for(j = 0; j < mm; j++)
            {
                scanf("%c", &a[i][j]);
                map[i][j] = 1000000;
            }
        }
        flag = false;
        n.px = n.py = -1;
        n.x = n.y = n.time = 0;
        priority_queue<node> Q; //建立优先队列
        Q.push(n);
        while(!Q.empty())
        {
            m = Q.top();
            Q.pop();
            if(m.x == nn-1 && m.y == mm-1)  //找到目标
            {
                flag = true;
                break;
            }
            for(i = 0; i < 4; i++)
            {
                n.x = m.x + xx[i];
                n.y = m.y + yy[i];
                if(n.x>=0 && n.x<nn && m.y>=0 && m.y<mm && a[n.x][n.y] != 'X')
                {
                    if(a[n.x][n.y] == '.') n.time = m.time + 1;
                    else n.time = m.time + (a[n.x][n.y] - '0') + 1; //打怪消耗时间
                    if(n.time < map[n.x][n.y])
                    {
                        //记录来该坐标的点(x,y)
                        ch[n.x][n.y].px = m.x;
                        ch[n.x][n.y].py = m.y;
                        map[n.x][n.y] = n.time; //更新该点时间
                        Q.push(n);
                    }
                }
            }
        }

        if(flag)    //找到目标后
        {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n", m.time);
            stack<node> st; //用到stack盏
            n.x = nn-1;
            n.y = mm-1;
            st.push(n);
            while(1)
            {
                m = st.top();
                if(m.x==0 && m.y==0)
                    break;
                n.x = ch[m.x][m.y].px;
                n.y = ch[m.x][m.y].py;
                st.push(n);     //push每一个坐标之前的点
            }
            ant = 1;
            st.pop();
            while(!st.empty())
            {
                m = st.top();
                st.pop();
                if(a[m.x][m.y] == '.')  //该点是普通的点
                {
                    printf("%ds:(%d,%d)->(%d,%d)\n", ant++,
                       ch[m.x][m.y].px, ch[m.x][m.y].py, m.x, m.y);
                }
                else    //否则是打怪的点
                {
                    printf("%ds:(%d,%d)->(%d,%d)\n", ant++,
                       ch[m.x][m.y].px, ch[m.x][m.y].py, m.x, m.y);
                    for(i = 0; i < a[m.x][m.y]-'0'; i++)
                    {
                        printf("%ds:FIGHT AT (%d,%d)\n", ant++, m.x, m.y);
                    }
                }
            }
            printf("FINISH\n");
        }
        else    //去不到目标
        {
            printf("God please help our poor hero.\n");
            printf("FINISH\n");
        }
    }

    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值