PAT1031 Hello World for U

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

 

 

 

 

 

 

 

#include <iostream>
#include <iomanip>
#include <string>
using namespace std;

int main()
{
    string str;
    cin>>str;
    int length = str.length();
    int n1 = length/3;
    int n2;
    if (length%3 == 0)
    {
        n1--;
        n2 = n1 + 3;
    }
    else
    {
        n2 = n1 + length%3;
    }
    for (int i = 0; i < n1; i++)
    {
        cout<<str[i];
        for (int j = 0; j < n2 - 2; j++)
        {
            cout<<" ";
        }
        cout<<str[length - 1 -i]<<endl;
    }
    for (int i = length - n1 - n2; i < length - n1; i++)
    {
        cout<<str[i];
    }
    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值