#POJ2376#Cleaning Shifts(贪心 -> 最小区间覆盖)

15 篇文章 0 订阅

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22465 Accepted: 5622

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.


题意:

农夫约翰让他的奶牛们打扫谷仓。他把一天分成T个时间段,T<=1000000

第一个时间段为1,最后一个时间段为T

i头奶牛愿意从第Si个时间段工作到第Ti个时间段。

问最少需要多少奶牛,才能保证每一个时间段都有奶牛在工作。

如果不能保证,则输出-1.


很经典的一个最小区间覆盖问题,按左端点排序,用一个变量标记现在已经覆盖到的最右点,

然后找一个左端点在覆盖范围内的最右点为新的标记点,并选中这条线段。


Code:

Status Accepted
Time 32ms
Memory 860kB
Length 1252
Lang G++
Submitted
Shared

#include<iostream> 
#include<cstdio> 
#include<cstdlib> 
#include<cmath> 
#include<algorithm> 
#include<vector> 
#include<queue> 
#include<cstring> 
using namespace std; 
  
const int Max = 25000; 
  
struct node{ 
    int l, r; 
    bool operator < (const node & X) const{ 
        if(l == X. l)   return r < X.r; 
        return l < X. l; 
    } 
}Cow[Max + 5]; 
  
int N; 
  
bool  getint(int & num){ 
    char c;    int flg = 1;    num = 0; 
    while((c = getchar()) < '0' || c > '9'){ 
        if(c == '-')    flg = -1; 
        if(c == -1)     return 0; 
    } 
    while(c >= '0' && c <= '9'){     
        num = num * 10 + c - 48; 
        if((c = getchar()) == -1)   return 0; 
    } 
    num *= flg; 
    return 1; 
} 
  
int main(){ 
	int N, T;
    while(getint(N) && getint(T)){ 
        for(int i = 1; i <= N; ++ i){
            getint(Cow[i].l), getint(Cow[i].r);
			if(Cow[i].l > Cow[i].r)	swap(Cow[i].l, Cow[i].r);
		}	
        sort(Cow + 1, Cow + 1 + N);
		int rit = 0, i = 1, flg = 1, Ans = 0;
		while(flg <= T){
			for( ; i <= N && Cow[i].l <= flg; ++ i)	if(Cow[i].r > rit)
				rit = Cow[i].r;
			if(rit >= flg)	flg = rit + 1,	++ Ans;
			else break;
		}
		if(flg <= T)	puts("-1");
		else printf("%d\n", Ans);
    } 
    return 0; 
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值