poj-2376-Cleaning Shifts

 

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

大意:FJ安排N头奶牛中的若干只做清洁。他分了T个时间段,而奶牛会在某段时间中有空。FJ要求每个时间段里必须有至少一头奶牛,求他最少需要安排几头奶牛。

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

 

 

 

这显然是一道贪心题。

至于怎么贪心...........这就是个好问题了。

按照开始时间贪心是错误的,有反例。(很好找,所以不多阐述。eg.[1,3][2,4][3,5])

所以应该让结束时间越大越好。(凭直觉可证)

下为我写的丑陋到爆的代码。

 

#include<cstdio>
#include<algorithm>
using namespace std;
int n,t,lst,ans;
struct nde
{
	int a,b;
}cw[25005];
bool cmp(nde p,nde q)
{
	if(p.a!=q.a) return p.a<q.a;
	return p.b>q.b;
}
int main()
{
	int i,j,k,l,f;
	scanf("%d%d",&n,&t);
	for(i=1;i<=n;i++) scanf("%d%d",&cw[i].a,&cw[i].b);
	sort(cw+1,cw+n+1,cmp);
	for(i=1;i<=n;i++)
	{
		f=0;
		if(lst<cw[i].a-1) {printf("-1");return 0;}
		for(j=i,k=lst;cw[j].a<=lst+1&&j<=n;j++)
			if(cw[j].b>k) {k=cw[j].b;l=j;i=l;f=1;}
		if(f) ans++;lst=k;
	}
	if(lst<t) {printf("-1");return 0;}
	printf("%d",ans);
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值